ConfigServer Services
Server Management Services from Way to The Web Ltd

I've changed a setting in the cPanel front-end but MailScanner seems to be ignoring the setting.

  Print
1. Check the appropriate ruleset file in /usr/mailscanner/etc/rules/, (i.e. spam.scanning.rules if you have changed the Spam Scanning setting, spamhigh.action.rules if you have changed the High Scoring Spam action setting, spamhigh.score.rules if you've changed the score for High Scoring Spam, etc.) to make sure it is listed correctly for the domain in that file.

2. If it is correct in the ruleset file, make sure that if you are forwarding another domain's emails to this domain, that domain also has the same setting in the cPanel front-end and the ruleset files.

3. If the ruleset file is not correct, check for the cron job that updates the rules files from the cPanel front-end settings. There should be a file called /etc/crond/mscpanel.sh. Check also that crond is running. Restart crond (type 'service crond restart' at the shell prompt), wait 10 minutes and check the ruleset files again to see if it is now correct.

4. If you are checking whether spam is being deleted when MS has been configured to delete spam, make sure to check the actual mail delivery (either login to the appropriate mailbox or check exim_mainlog to see whether the deliver was completed) rather than use what it says in MailWatch under Spam Action, as that is not always correct.

5. If you have been through all the checks above and the problem does not resolve, log a ticket on our helpdesk for assistance.

Self-Hosted Help Desk Software by SupportPal.

Login

 
Forgot password?
Register now